Installing or Updating Flash

globaledit Support -


Flash Player is required to view the globaledit platform. Always make sure your Flash Player is up to date by going here.

The Chrome browser does not require manual updates of Flash, but if you are using Firefox, for example, you will need to watch for available updates.

If your browser says that Flash is outdated, you can update Flash manually by downloading and installing the latest version from Adobe.

  1. Go to Adobe's Flash Player download page and download the Flash installer.
  2. Click the menu button and then click Quit.
  3. Open the file you downloaded (i.e. install_flash_player_osx_intel.dmg).
  4. In the Finder, open the Install Adobe Flash Player.app to run the installer, then follow the instructions.

 

Flash Plugin Not Working

If Adobe's test page does not show that Flash is working even though you have installed the latest version, your Flash plugin may be disabled. To make sure that Flash is enabled...

  1. Click the menu button and choose Add-ons. The Add-ons Manager tab will open.
  2. In the Add-ons Manager tab, select the Plugins panel.

If the Flash plugin is disabled, select Always Activate in its drop-down menu.

 

Clearing Your Flash Cache

Click HERE to access detailed instructions.

Can't find what you're looking for?
We're here to help. Send us a support ticket.
SEND